LaTeXing - Professional Typesetting

An extension for Sublime Text which makes your life
easier and more comfortable while creating your documents.

TexCount Failure

Problems while settings up the stable version of LaTeXing

TexCount Failure

Postby AraAdkins » Tue Mar 11, 2014 2:29 pm

Texcount is consistently returning a count of zero when being used from within Sublime. Run from the command line, it works as expected.

OS: Windows 8/8.1 (two computers)
TeX Distro: MikTeX
Sublime Version: 3059
AraAdkins
 
Posts: 4
Joined: Tue Mar 11, 2014 2:22 pm

Re: TexCount Failure

Postby Chris » Thu Mar 13, 2014 5:28 pm

Mm, very difficult decision right now what to say, I would say you could try to fetch updates for MikTeX perhaps the texcount script is slightly out of date and not supporting all input arguments LaTeXing is using.
Chris
Site Admin
 
Posts: 75
Joined: Fri Nov 08, 2013 12:40 pm

Re: TexCount Failure

Postby AraAdkins » Thu Mar 13, 2014 11:31 pm

I've tried updating MiKTeX with no success.
AraAdkins
 
Posts: 4
Joined: Tue Mar 11, 2014 2:22 pm

Re: TexCount Failure

Postby Chris » Mon Mar 17, 2014 1:45 pm

Mmm very strange since LaTeXing is doing nothing fancy with this. I tried it on a Windows PC this morning (just to verified it again and it was working fine). So you call the following from your command line it works like expected?

Code: Select all
texcount.exe -0 test.tex
Chris
Site Admin
 
Posts: 75
Joined: Fri Nov 08, 2013 12:40 pm

Re: TexCount Failure

Postby AraAdkins » Mon Mar 17, 2014 2:44 pm

That gets the following response:
> 1597+15+0 (6/0/0/0) Total

Which is as expected for the document. Texcount when run from within sublime still returns zero.

There are no messages written to the sublime console when it's called by LaTeXing.
AraAdkins
 
Posts: 4
Joined: Tue Mar 11, 2014 2:22 pm

Re: TexCount Failure

Postby Chris » Thu Mar 20, 2014 1:42 pm

There has to be something wrong with perl or so, could you run a system check and drop an email at info@latexing.com?
Chris
Site Admin
 
Posts: 75
Joined: Fri Nov 08, 2013 12:40 pm

Re: TexCount Failure

Postby AraAdkins » Thu Mar 20, 2014 1:55 pm

Done.
AraAdkins
 
Posts: 4
Joined: Tue Mar 11, 2014 2:22 pm


Return to Technical Support

Who is online

Users browsing this forum: No registered users and 2 guests

cron