LaTeXing - Professional Typesetting

An extension for Sublime Text which makes your life
easier and more comfortable while creating your documents.

[Solved] .bbl not generated

Report Problems with the Testing Version.

[Solved] .bbl not generated

Postby wombat67 » Wed Nov 13, 2013 8:13 pm

hi..

I'm trying to get bibtex to recognize my bibliography entries, but no luck.

I think the root of the problem is in the Output/PatentApplication.stderr.log :

Latexmk: Run number 1 of rule 'pdflatex'
Latexmk: Non-existent bbl file 'Output/PatentApplication.bbl'
No file PatentApplication.bbl.
Latexmk: Failed to find one or more bibliography files
PatentApplication-blx.bib
==== Force_mode is on, so I will continue. But there may be problems ===
Latexmk: Summary of warnings:
Latex failed to resolve 1 citation(s)
Latexmk: I WON'T RUN 'bibtex Output/PatentApplication' because I don't find the following files:
PatentApplication-blx.bib
Latexmk: Run number 2 of rule 'pdflatex'
Latexmk: Non-existent bbl file 'Output/PatentApplication.bbl'
No file PatentApplication.bbl.
Latexmk: Failed to find one or more bibliography files
PatentApplication-blx.bib
==== Force_mode is on, so I will continue. But there may be problems ===
Latexmk: Summary of warnings:
Latex failed to resolve 1 citation(s)
Latexmk: Run number 3 of rule 'pdflatex'
Latexmk: Non-existent bbl file 'Output/PatentApplication.bbl'
No file PatentApplication.bbl.
Latexmk: Failed to find one or more bibliography files
PatentApplication-blx.bib
==== Force_mode is on, so I will continue. But there may be problems ===
Latexmk: Summary of warnings:
Latex failed to resolve 1 citation(s)

There is an Output/PatentApplication-blx.bib.

I believe it's because the following options are set:

"output_directory": true
"output_directory_mode": 0

and pdflatex isn't looking in the Output subdirectory. If i set output_directory to false it works. I've attached the project. I prefer to use the output directory to keep the build files separate from the source. As an aside, the latexing clean of all non-essential files missed the PatentApplication-blx.bib.

not a blocker, but could save someone some time
Attachments
latexing_baug2.zip
(11.91 KiB) Downloaded 2891 times
wombat67
 
Posts: 7
Joined: Mon Nov 11, 2013 10:56 pm

Re: .bbl not generated for 1.1.0.alpha4

Postby Chris » Wed Nov 13, 2013 8:34 pm

No that is defiantly working. Please verify this kind of problems always with the stable version first. I tried your example and it is working without a problem. Please verify that you are using the latest latexmk version (4.37), that is most times the problem if related to output directories.

Btw. the latest LaTeXing version is also 1.1.0-alpha7.
Chris
Site Admin
 
Posts: 75
Joined: Fri Nov 08, 2013 12:40 pm

Re: .bbl not generated for 1.1.0.alpha4

Postby wombat67 » Wed Nov 13, 2013 9:15 pm

ok. All i know is that it was failing then i turned the output_directory to false and it was working. Just did it again to confirm.

My latexmk is 4.35 and was installed as part of the MacTeX-2013 package created on May 30, 2013. I'm hesitant to upgrade it because:
- i'm not sure how to do it properly
- i don't know what other issues i might introduce
- there is an acceptable workaround
so i'll leave it at that. If someone else runs into this, maybe it helps.
wombat67
 
Posts: 7
Joined: Mon Nov 11, 2013 10:56 pm

Re: .bbl not generated for 1.1.0.alpha4

Postby wombat67 » Wed Nov 13, 2013 9:29 pm

dug into it a bit..

sudo tlmgr update --self
sudo tlmgr update latexmk

upgrades to latexmk v. 4.37 and now the problem is resolved. Thanks!
wombat67
 
Posts: 7
Joined: Mon Nov 11, 2013 10:56 pm

Re: .bbl not generated for 1.1.0.alpha4

Postby Chris » Thu Nov 14, 2013 8:56 am

Great, glad that I leaded you in the right direction.
Chris
Site Admin
 
Posts: 75
Joined: Fri Nov 08, 2013 12:40 pm


Return to Problems

Who is online

Users browsing this forum: No registered users and 1 guest

cron